Product Search

    SEARCH NOW FOR ALL YOUR NOVOTECHNIK SOLUTIONS

    Radwell is here to supply you with all your plant floor needs.

    Radwell is not an authorised distributor, reseller or representative of the products featured on this website. All product names, trademarks, brands and logos used on this site are the property of their respective owners. The depiction, description or sale of products featuring these names, trademarks, brands and logos is for identification purposes only and is not intended to indicate any affiliation with or authorisation by any rights holder.

    Filter Results
    Results 301-350 of 589.
    NOVOTECHNIK GP 5 P 4501 A502

    NOVOTECHNIK

    GP 5 P 4501 A502

    009102, MULTI-TURN ROTARY POTENTIOMETER WITH 3, 5 OR 10 TURNS,
    €738.66 Price with VAT: €879.01 Buy Surplus As Low As €443.20 Price with VAT: €527.41
    €443.20 Price with VAT: €527.41
    NOVOTECHNIK IP6515-A502

    NOVOTECHNIK

    IP6515-A502

    ROTARY TRANSDUCER
    €428.22 Price with VAT: €509.58 Buy Surplus As Low As €56.66 Price with VAT: €67.43
    €56.66 Price with VAT: €67.43
    NOVOTECHNIK RFC 4853 603 111 201

    NOVOTECHNIK

    RFC 4853 603 111 201

    ROTARY SENSOR, TOUCHLESS, 2-PART, MECHANICALLY DECOUPLED, IP67, IP6K9K
    €186.89 Price with VAT: €222.40 Buy Surplus As Low As €112.13 Price with VAT: €133.44
    €112.13 Price with VAT: €133.44
    NOVOTECHNIK EEM 33-80

    NOVOTECHNIK

    EEM 33-80

    005623, 90 DEGREE, 7 PIN, IP40, AW
    €61.41 Price with VAT: €73.07 Buy Surplus As Low As €37.38 Price with VAT: €44.48
    €37.38 Price with VAT: €44.48
    NOVOTECHNIK EEM 33-79

    NOVOTECHNIK

    EEM 33-79

    005622, STRAIGHT DUSTPROOF, 7 PIN, IP40, AW
    €61.41 Price with VAT: €73.07 Buy Surplus As Low As €37.38 Price with VAT: €44.48
    €37.38 Price with VAT: €44.48
    NOVOTECHNIK RFC-4801-609-322-256

    NOVOTECHNIK

    RFC-4801-609-322-256

    RFC-4801-609-322-256
    €151.29 Price with VAT: €180.04 Buy Surplus As Low As €90.78 Price with VAT: €108.02
    €90.78 Price with VAT: €108.02
    NOVOTECHNIK Z-TP1-P08

    NOVOTECHNIK

    Z-TP1-P08

    SLIDER POSITION MAGNET, GUIDED POSITION INDICATOR FOR TP1, ITEM # 005695
    €50.73 Price with VAT: €60.37 Buy Surplus As Low As €31.15 Price with VAT: €37.07
    €31.15 Price with VAT: €37.07
    NOVOTECHNIK Z-RFC-P08

    NOVOTECHNIK

    Z-RFC-P08

    POSITION MARKER, FOR FRONTAL FIXATION, WITH 2 SCREWS, OR WITH THREADED PIN M5
    €35.95 Price with VAT: €42.79 Buy Surplus As Low As €22.47 Price with VAT: €26.74
    €22.47 Price with VAT: €26.74
    NOVOTECHNIK EEM 33-66

    NOVOTECHNIK

    EEM 33-66

    005619, STRAIGHT, M8 3 PIN, IP67 - 5 METER UNSHIELDED CABLE, TS / TRS / TEX / TX2
    €68.53 Price with VAT: €81.55 Buy Surplus As Low As €41.83 Price with VAT: €49.78
    €41.83 Price with VAT: €49.78
    NOVOTECHNIK 105083

    NOVOTECHNIK

    105083

    CANNON CONNECTOR, RIGHT ANGLE CANNON CONNECTOR, AWS / IGP / IPS
    €75.65 Price with VAT: €90.02 Buy Surplus As Low As €45.39 Price with VAT: €54.01
    €45.39 Price with VAT: €54.01
    NOVOTECHNIK MAP-4010-001-101

    NOVOTECHNIK

    MAP-4010-001-101

    MEASURING DEVICE, MULTIFUNCTIONAL, WITH DISPLAY, MAP4000 SERIES
    €536.64 Price with VAT: €638.61 Buy Surplus As Low As €322.16 Price with VAT: €383.38
    €322.16 Price with VAT: €383.38
    NOVOTECHNIK TRS 75 A 502

    NOVOTECHNIK

    TRS 75 A 502

    POSITION TRANSDUCER, 55MM STROKE, 90 DEGREE CONNECTOR, EEM 33-72
    €429.85 Price with VAT: €511.52 Buy Surplus As Low As €258.09 Price with VAT: €307.12
    €258.09 Price with VAT: €307.12
    NOVOTECHNIK MUW200-4

    NOVOTECHNIK

    MUW200-4

    054103, SIGNAL CONDITIONERS FOR USE WITH POTENTIOMETERS, OUTPUT = 4..20MA
    €400.58 Price with VAT: €476.69 Buy Surplus As Low As €220.22 Price with VAT: €262.06
    €220.22 Price with VAT: €262.06
    NOVOTECHNIK Z-TLM-P05

    NOVOTECHNIK

    Z-TLM-P05

    DISCONTINUED BY MANUFACTURER, GUIDED POSITION MARKER
    Buy Surplus As Low As €170.87 Price with VAT: €203.34
    €170.87 Price with VAT: €203.34
    NOVOTECHNIK RFC4851-636-122-501

    NOVOTECHNIK

    RFC4851-636-122-501

    ROTARY POTENTIOMETER
    €258.98 Price with VAT: €308.18 Buy Surplus As Low As €129.93 Price with VAT: €154.62
    €129.93 Price with VAT: €154.62
    NOVOTECHNIK 002333

    NOVOTECHNIK

    002333

    PNEUMATIC TRANSDUCER
    €175.32 Price with VAT: €208.63 Buy Surplus As Low As €88.11 Price with VAT: €104.85
    €88.11 Price with VAT: €104.85
    Repair Yours Contact Us
    NOVOTECHNIK TE1-0050-102-422-101

    NOVOTECHNIK

    TE1-0050-102-422-101

    049681, LINEAR POTENTIOMETER WITH INTEGRATED SIGNAL CONDITIONER,
    €592.71 Price with VAT: €705.33 Buy Surplus As Low As €355.98 Price with VAT: €423.62
    €355.98 Price with VAT: €423.62
    NOVOTECHNIK TE1-0050-101-422-202

    NOVOTECHNIK

    TE1-0050-101-422-202

    049382, LINEAR POTENTIOMETER WITH INTEGRATED SIGNAL CONDITIONER,
    €542.87 Price with VAT: €646.02 Buy Surplus As Low As €325.72 Price with VAT: €387.61
    €325.72 Price with VAT: €387.61
    NOVOTECHNIK TE1-0025-102-422-101

    NOVOTECHNIK

    TE1-0025-102-422-101

    049631, LINEAR POTENTIOMETER WITH INTEGRATED SIGNAL CONDITIONER,
    €580.25 Price with VAT: €690.50 Buy Surplus As Low As €348.86 Price with VAT: €415.15
    €348.86 Price with VAT: €415.15
    NOVOTECHNIK GP 10 P 4501 A502

    NOVOTECHNIK

    GP 10 P 4501 A502

    009103, MULTI-TURN ROTARY POTENTIOMETER WITH 3, 5 OR 10 TURNS,
    €738.66 Price with VAT: €879.01 Buy Surplus As Low As €443.20 Price with VAT: €527.41
    €443.20 Price with VAT: €527.41
    NOVOTECHNIK TE1-0025-102-421-202

    NOVOTECHNIK

    TE1-0025-102-421-202

    049612, LINEAR POTENTIOMETER WITH INTEGRATED SIGNAL CONDITIONER,
    €580.25 Price with VAT: €690.50 Buy Surplus As Low As €348.86 Price with VAT: €415.15
    €348.86 Price with VAT: €415.15
    NOVOTECHNIK TE1-0025-101-422-101

    NOVOTECHNIK

    TE1-0025-101-422-101

    049331, LINEAR POTENTIOMETER WITH INTEGRATED SIGNAL CONDITIONER,
    €531.30 Price with VAT: €632.25 Buy Surplus As Low As €319.49 Price with VAT: €380.20
    €319.49 Price with VAT: €380.20
    NOVOTECHNIK T 0075

    NOVOTECHNIK

    T 0075

    023204, LINEAR POTENTIOMETERS WITH OR WITHOUT RETURN SPRINGS,
    €454.77 Price with VAT: €541.17 Buy Surplus As Low As €273.22 Price with VAT: €325.13
    €273.22 Price with VAT: €325.13
    NOVOTECHNIK P 4502 A502

    NOVOTECHNIK

    P 4502 A502

    006209, ROTARY SHAFT-TYPE POTENTIOMETERS,
    €502.83 Price with VAT: €598.36 Buy Surplus As Low As €301.70 Price with VAT: €359.02
    €301.70 Price with VAT: €359.02
    NOVOTECHNIK P 4501-S0059

    NOVOTECHNIK

    P 4501-S0059

    006220, ROTARY SHAFT-TYPE POTENTIOMETERS,
    €450.32 Price with VAT: €535.88 Buy Surplus As Low As €270.55 Price with VAT: €321.95
    €270.55 Price with VAT: €321.95
    NOVOTECHNIK MUP 110-0

    NOVOTECHNIK

    MUP 110-0

    054010, SIGNAL CONDITIONERS FOR USE WITH POTENTIOMETERS, OUTPUT = 0..20MA
    €573.13 Price with VAT: €682.03 Buy Surplus As Low As €344.41 Price with VAT: €409.85
    €344.41 Price with VAT: €409.85
    NOVOTECHNIK MUP 080-113

    NOVOTECHNIK

    MUP 080-113

    054221, SIGNAL CONDITIONERS FOR USE WITH POTENTIOMETERS, OUTPUT = 4..20MA
    €404.04 Price with VAT: €480.81 Buy Surplus As Low As €242.96 Price with VAT: €289.12
    €242.96 Price with VAT: €289.12
    NOVOTECHNIK EEM 33-94

    NOVOTECHNIK

    EEM 33-94

    005648, 90 DEGREE, M16 6 PIN, IP67 - SHIELDED, SOLDER TERMINAL, TP1 / TH1
    €68.53 Price with VAT: €81.55 Buy Surplus As Low As €41.83 Price with VAT: €49.78
    €41.83 Price with VAT: €49.78
    NOVOTECHNIK T 0100

    NOVOTECHNIK

    T 0100

    023205, LINEAR POTENTIOMETERS WITH OR WITHOUT RETURN SPRINGS,
    €463.67 Price with VAT: €551.76 Buy Surplus As Low As €278.56 Price with VAT: €331.48
    €278.56 Price with VAT: €331.48
    2 3 4 5 6 7 8 9 10 11 12